pylint on Leopard

If you followed my instructions on installin Python on Leiopard you get a broken pylint.

Remove all pylint/logilab traces in /opt/local/lib/python2.5/site-packages/easy-install.pth. Then try:

$ sudo rm -Rf /opt/local/lib/python2.5/site-packages/pylint*
$ sudo rm -Rf /opt/local/lib/python2.5/site-packages/logilab*
$ wget ftp://ftp.logilab.fr/pub/pylint/pylint-0.13.2.tar.gz
$ wget ftp://ftp.logilab.fr/pub/common/logilab-common-0.25.1.tar.gz
$ wget ftp://ftp.logilab.fr/pub/astng/logilab-astng-0.17.1.tar.gz
$ tar logilab-common-0.25.1.tar.gz 
$ tar xzvf logilab-common-0.25.1.tar.gz 
$ cd logilab-common-0.25.1
$ python manage.py test mypl2
$ sudo python setup.py install
$ cd ..
$ tar xzvf logilab-astng-0.17.1.tar.gz
$ cd logilab-astng-0.17.1
$ sudo python setup.py install
$ cd ..
$ tar xzvf pylint-0.13.2.tar.gz 
$ cd pylint-0.13.2
$ sudo python setup.py install
$ cd ..

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s