Use less comments in code!

self.failUnlessEqual(response.status_code, 200)

If you use variable and function name which are descriptive you seldom need to describe what a line of code does, since the variables and functions already do. The code above e.g. reads very nicely: „fail unless the status code of the response is 200“.

So the comment below this line is superfluous. And superfluous things in program code make the code harder to read and harder to maintain.

Much better are comments who describe what some obscure code does where one can’t deduct the functionality from reading the line alone.

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

Du kommentierst mit Deinem Abmelden / Ändern )


Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )


Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s